Betterez status

Back-office UI issues around 1:11PM EST time

resolved
Back office website
partial-outage
The deployment process did not push the needed files in the CDN source.
Sep 11, 2024 4:33 PM
Resolved
A re-deployment was done and a validation was added to avoid the same issue in the future.