Status

Service degradation and disruption

resolved
Back office website - transpcomp
partial-outage
Incompatible instance types launched in the autoscaling group starting on 2026-08-13 07:02:47 UTC.
Aug 14, 2026 9:03 PM
Identified
Issue identified at 2026-08-13 13:58:00 UTC
Aug 14, 2026 9:05 PM
Investigating
2026-08-12 21:30:01 UTC: An engineer performed a routine update to the Launch Template version via the AWS Console. Due to a AWS console UI bug, unintended Launch Template Override settings were saved to the Auto Scaling Group forcing the ASG to launch instances with the wrong instance type. 2026-08-13 07:02:47 UTC: The failure cycle initiated. According to the ASG activity log, the group scaled or replaced an instance, launching the first incompatible a1.medium instance. A thorough investigation revealed the root cause to be an intermittent user interface (UI) regression within the Amazon Web Services (AWS) Management Console. This platform defect silently applied incompatible infrastructure configurations during a standard launch update.
Aug 14, 2026 9:05 PM
Resolved
2026-08-13 14:11:00 UTC (Resolution): The fix was applied to the ASG. Engineers manually disabled the override settings and terminated all active a1.medium instances, forcing the ASG to launch correct, healthy t4g.large (ARM) instances and fully restore service. Our engineering team identified the underlying vendor fault, verified the timeline through ASG activity logs, captured visual proof of the issue, restored full system health by 14:11 UTC on August 13, and established immediate safeguards to prevent recurrence while AWS addresses the defect. We have successfully replicated this behavior in a controlled environment and captured full UI state documentation. A critical bug report has been submitted to AWS Engineering. We are actively coordinating with AWS Support to ensure this console bug is remediated. Immediate Procedural Safeguard: All manual updates via the AWS Console now require an explicit reset step to clear any background override flags before committing changes. AWS Support Tracking: We are actively monitoring our escalation ticket with AWS for a permanent fix on their platform frontend.