Betterez status

Slowness and time out in some services

resolved
Accounts API Inventory API Trip Search API Notifications API Sales API
partial-outage
An excess load in the lexicons endpoints of the Accounts API introduced abnormal latency on all of the API endpoints causing a cascading failure the listed services.
Jun 2, 2025 3:02 PM
Resolved
The latency caused a failure in the Notifications API that took servers out of the autoscaling group. AWS autoscaling groups re-acted as expected increasing the number of instances and removing unhealthy instances of the pools. Remediation: The bug in Notifications API have been identified and fixed. The lexicon endpoints have been isolated from the rest of the Accounts API pool into their own autoscaling group to allow for unexpected bursts in the future.