Time outs on Sales API affecting betterez-app and websales
resolved
Back office website
Websales
Sales API
partial-outage
On Tuesday 2026-07-07T10:57 UTC to 2026-07-07T12:05 UTC
Jul 7, 2026 11:15 AM
Investigating
We notice some time outs on the sales api. Nothing suspicious in the logs. Start monitoring the requests to the api.
Jul 7, 2026 11:30 AM
Identified
Requests taking too long to complete, blocking the thread and causing time outs that multiply until the thread is blocked and the request fails. Autoscaling group was not able to recover the instance.
Jul 7, 2019 11:53 AM
Mitigating
Started the rollback of the deployment to the previous version.
Jul 7, 2019 12:05 PM
Resolved
Completed the rollback of the deployment to the previous version.
Jul 7, 2026 4:55 PM
Investigating
While investigating the root cause a new unbounded query was discovered. The query was introduced to solve a transient bug on the cancelation process.
Jul 8, 2026 10:00 AM
Resolved
The unbounded query was identified and fixed. A new AI driven check was added to the codebase to try to detect unbounded queries in the future.